Microsoft Excel:

  Таблицы и VBA. Справочник.
  Вопросы и Ответы. Советы. Примеры.
Меню Заметки | XL : Диаграмма без отрицательных значений


Rambler's Top100


Counter CO.KZ

Если Вам необходимо сделать так, чтобы все отрицательные значения, на диаграмме отображались как 0.



Но, при этом :
1) исходные данные должны остаться без изменений, проще говоря, в ячейках должны остаться числа с минусом (см. скриншот)
2) нельзя разрывать связь между диаграммой и ячейками листа
3) нельзя(или крайне нежелательно) использовать дополнительные ячейки, то :

Microsoft Excel 95-2003

Вариант I (а)

  • После построения диаграммы, просто наведите курсор мышки на Ось значений
  • Кликните правой кнопкой мышки
  • В появившемся контекстном меню выберите команду Формат оси
  • В стандартном диалоговом окне, выделите закладку Шкала
  • В текстовом поле, напротив, минимальное значение: введите 0 и подтвердите свой выбор кнопкой Ok

    Вариант I (б)

  • После построения диаграммы, выделите Ось значений
  • В меню Формат выберите команду Выделенная ось (или воспользуйтесь сочетанием клавиш CTRL+1)
  • В стандартном диалоговом окне, выделите закладку Шкала
  • В текстовом поле, напротив, минимальное значение: введите 0 и подтвердите свой выбор кнопкой Ok



    Microsoft Excel 2007

    Вариант I (а)

  • После построения диаграммы, выделите Вертикальную ось (значений)
  • Кликните правой кнопкой мышки
  • В появившемся контекстном меню выберите команду Формат оси
  • В стандартном диалоговом окне, напротив, минимальное значение: установите "переключатель" как Фиксированное, а в текстовом поле введите 0 и кликните кнопку Закрыть

    Вариант I (б)

  • После построения диаграммы выделите Вертикальную ось (значений)
  • На ленте выберите закладку Формат
  • Кликните кнопку Формат выделенного об'екта
  • В стандартном диалоговом окне, напротив, минимальное значение: установите "переключатель" как Фиксированное, а в текстовом поле введите 0 и кликните кнопку Закрыть



    Microsoft Excel 95-2003

    Вариант II

  • В меню Вставка выберите пункт Имя и команду Присвоить
  • В стандартном диалоговом окне, в текстовое поле Имя: введите любое допустимое имя формулы, например, ИСТОЧНИК
  • А в текстовое поле Формула: введите следующую формулу, где Данные!$C$3:$C$7 это диапазон с числами, на основании которых построена диаграмма.

    =ЕСЛИ(Данные!$C$3:$C$7>0;Данные!$C$3:$C$7;0)

    Совет : Если в момент создания именованной формулы, рабочий лист с именем "Данные" активен, то в формуле его можно не указывать.

  • Теперь, выделите ряд на диаграмме, и прямо в строке формул, измените источник, т.е. замените Данные!$C$3:$C$7 на Данные!ИСТОЧНИК или ИмяВашейКниги.xls!ИСТОЧНИК








    Microsoft Excel 2007

    Вариант II

  • На ленте выберите закладку Формула
  • Кликните кнопку Диспетчер имён
  • В стандартном диалоговом окне, кликните кнопку Создать
  • Затем, уже в другом диалоговом окне, в текстовое поле Имя: введите любое допустимое имя формулы, например, ИСТОЧНИК
  • А в текстовое поле Диапазон: введите следующую формулу, где Данные!$C$3:$C$7 это диапазон с числами, на основании которых построена диаграмма.

    =ЕСЛИ(Данные!$C$3:$C$7>0;Данные!$C$3:$C$7;0)

    Совет : Если в момент создания именованной формулы, рабочий лист с именем "Данные" активен, то в формуле его можно не указывать.

  • Теперь, выделите ряд на диаграмме, и прямо в строке формул, измените источник, т.е. замените Данные!$C$3:$C$7 на Данные!ИСТОЧНИК или ИмяВашейКниги.xlsx!ИСТОЧНИК

    Примечание : Если Вы не пользуетесь строкой формул, то всех версиях Excel, такую замену можно произвести и в Исходных данных.



    Пример можно скачать здесь


    Комментарий : Несмотря на то, что второй способ более трудоёмкий, в реальности он позволяет строить диаграммы на основании и других формул, что даёт Вам простор для творчества и совершенствования. А если применение стандартных формул не даст нужного эффекта, то имейте ввиду, что источником данных для диаграммы, может быть и пользовательская функция (UDF)


    Автор : Климов Павел Юрьевич
  • © 2004-2016 Климов П.Ю. Все права защищены. WebDesign & Error's Klimoff